GHSA-65xw-pcqw-hjrh

Apache Airflow Cross-site Scripting Vulnerability

En bref

Publiée
Mise à jour
CVE
CVE-2021-45229
Alias
BIT-airflow-2021-45229, PYSEC-2022-29
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

Description

It was discovered that the "Trigger DAG with config" screen was susceptible to XSS attacks via the `origin` query argument. This issue affects Apache Airflow versions 2.2.3 and below.

Paquets affectés

PaquetVersions
PyPI · apache-airflowintroduced 0, fixed 2.2.4rc1

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database