GHSA-6456-xjm5-g3pg
Cross-site scripting vulnerability exists in Jenkins and Stapler Plugin
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2018-1999007
- CVSS_V3
- CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Description
A cross-site scripting vulnerability exists in Jenkins 2.132 and earlier, 2.121.1 and earlier in the Stapler web framework's org/kohsuke/stapler/Stapler.java that allows attackers with the ability to control the existence of some URLs in Jenkins to define JavaScript that would be executed in another user's browser when that other user views HTTP 404 error pages while Stapler debug mode is enabled.
Paquets affectés
| Paquet | Versions |
|---|---|
| Maven · org.jenkins-ci.main:jenkins-core | introduced 0, fixed 2.121.2 |
| Maven · org.jenkins-ci.main:jenkins-core | introduced 2.122, fixed 2.132 |
| Maven · org.kohsuke.stapler:stapler-parent | introduced 0, fixed 1.250.1 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2018-1999007 ADVISORY
- https://github.com/jenkinsci/stapler/commit/03e221a81e8424709d1fbdf72ab814309dd8e13f WEB
- https://github.com/jenkinsci/jenkins PACKAGE
- https://jenkins.io/security/advisory/2018-07-18/#SECURITY-390 WEB
- https://www.oracle.com/security-alerts/cpuapr2022.html WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |