GHSA-5xm3-48v5-6h7v
Jenkins allows Remote Users to Obtain Sensitive Information from a Plugin Code
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2014-3667
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
Description
Jenkins before 1.583 and LTS before 1.565.3 does not properly prevent downloading of plugins, which allows remote authenticated users with the Overall/READ permission to obtain sensitive information by reading the plugin code.
Paquets affectés
| Paquet | Versions |
|---|---|
| Maven · org.jenkins-ci.main:jenkins-core | introduced 1.566, fixed 1.583 |
| Maven · org.jenkins-ci.main:jenkins-core | introduced 0, fixed 1.565.3 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2014-3667 ADVISORY
- https://github.com/jenkinsci/jenkins/commit/f0a29b562e14d837912c6b35fa4e81478563813a WEB
- https://access.redhat.com/errata/RHBA-2014:1630 WEB
- https://access.redhat.com/errata/RHSA-2016:0070 WEB
- https://access.redhat.com/security/cve/CVE-2014-3667 WEB
- https://bugzilla.redhat.com/show_bug.cgi?id=1147770 WEB
- https://github.com/jenkinsci/jenkins PACKAGE
- https://wiki.jenkins-ci.org/display/SECURITY/Jenkins+Security+Advisory+2014-10-01 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |