GHSA-5wv5-4vpf-pj6m
Pallets Project Flask is vulnerable to Denial of Service via Unexpected memory usage
At a glance
- Published
- Updated
- CVE
- CVE-2019-1010083
- Aliases
- PYSEC-2019-179
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
Description
The Pallets Project Flask before 1.0 is affected by unexpected memory usage. The impact is denial of service. The attack vector is crafted encoded JSON data. The fixed version is 1. NOTE this may overlap CVE-2018-1000656.
Affected packages
| Package | Versions |
|---|---|
| PyPI · flask | introduced 0, fixed 1.0 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-1010083 ADVISORY
- https://github.com/advisories/GHSA-5wv5-4vpf-pj6m ADVISORY
- https://github.com/pallets/flask PACKAGE
- https://github.com/pypa/advisory-database/tree/main/vulns/flask/PYSEC-2019-179.yaml WEB
- https://www.palletsprojects.com/blog/flask-1-0-released WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |