GHSA-5wjh-v7c8-wrhx

Moodle stored Cross-site Scripting

En bref

Publiée
Mise à jour
CVE
CVE-2021-32475
Alias
BIT-moodle-2021-32475
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Description

ID numbers displayed in the quiz grading report required additional sanitizing to prevent a stored XSS risk. Moodle 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8, 3.5 to 3.5.17 and earlier unsupported versions are affected.

Paquets affectés

PaquetVersions
Packagist · moodle/moodleintroduced 3.5, fixed 3.5.18
Packagist · moodle/moodleintroduced 3.8, fixed 3.8.9
Packagist · moodle/moodleintroduced 3.9, fixed 3.9.7
Packagist · moodle/moodleintroduced 3.10, fixed 3.10.4

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database