GHSA-5w6g-rc45-wvv9
Duplicate Advisory: Flowise OverrideConfig security vulnerability
Withdrawn ·
At a glance
- Published
- Updated
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Description
### Duplicate Advisory This advisory has been withdrawn because it is a duplicate of GHSA-5cph-wvm9-45gj. This link is maintained to preserve external references. ### Original Description Flowise before 2.1.4 allows configuration to be injected into the Chainflow during execution via the overrideConfig option, supported in both the frontend web integration and the backend Prediction API. Because this feature is enabled by default with no allow-list of permitted variables and relies on vm2 for sandboxing, an attacker can abuse it to achieve remote code execution and sandbox escape, denial of service by crashing the server, server-side request forgery, prompt injection, and server variable and data exfiltration. These issues are self-targeted and do not persist to other users.
Affected packages
| Package | Versions |
|---|---|
| npm · flowise | introduced 0, fixed 2.1.4 |
References
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-5cph-wvm9-45gj WEB
- https://nvd.nist.gov/vuln/detail/CVE-2024-58351 ADVISORY
- https://github.com/FlowiseAI/Flowise PACKAGE
- https://www.vulncheck.com/advisories/flowise-remote-code-execution-via-overrideconfig-parameter WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |