GHSA-5qwq-g2hx-r6f7

Hessian Lite for Apache Dubbo deserialization vulnerability

En bref

Publiée
Mise à jour
CVE
CVE-2022-39198
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

A deserialization vulnerability existed in dubbo hessian-lite 3.2.12 and its earlier versions, which could lead to malicious code execution. This issue affects Apache Dubbo 2.7.x version 2.7.17 and prior versions; Apache Dubbo 3.0.x version 3.0.11 and prior versions; Apache Dubbo 3.1.x version 3.1.0 and prior versions.

Paquets affectés

PaquetVersions
Maven · com.alibaba:hessian-liteintroduced 0, fixed 3.2.13
Maven · org.apache.dubbo:dubbointroduced 2.7.0, fixed 2.7.18
Maven · org.apache.dubbo:dubbointroduced 3.0.0, fixed 3.0.12
Maven · org.apache.dubbo:dubbointroduced 3.1.0, fixed 3.1.1

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database