GHSA-5pjj-7fq8-9gpf
Magento has an XML Injection vulnerability
At a glance
- Published
- Updated
- CVE
- CVE-2021-36028
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Description
Magento Commerce versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by an XML Injection vulnerability when saving a configurable product. An attacker with admin privileges can trigger a specially crafted script to achieve remote code execution.
Affected packages
| Package | Versions |
|---|---|
| Packagist · magento/project-community-edition | introduced 0, last affected 2.0.2 |
| Packagist · magento/community-edition | introduced 0, fixed 2.3.7-p1 |
| Packagist · magento/community-edition | 2.3.7 |
| Packagist · magento/community-edition | introduced 2.4.2-p1, fixed 2.4.2-p2 |
| Packagist · magento/community-edition | 2.4.2 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2021-36028 ADVISORY
- https://github.com/magento/magento2 PACKAGE
- https://helpx.adobe.com/security/products/magento/apsb21-64.html WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |