GHSA-5pcm-hx3q-hm94

PyTorch heap buffer overflow vulnerability

En bref

Publiée
Mise à jour
CVE
CVE-2024-31580
Alias
BIT-pytorch-2024-31580, PYSEC-2024-252, PYSEC-2024-328
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Description

PyTorch before v2.2.0 was discovered to contain a heap buffer overflow vulnerability in the component /runtime/vararg_functions.cpp. This vulnerability allows attackers to cause a Denial of Service (DoS) via a crafted input.

Paquets affectés

PaquetVersions
PyPI · torchintroduced 0, fixed 2.2.0

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database