GHSA-5m62-pw8w-7w9f

Apache Tomcat - Security constraints not correctly applied

En bref

Publiée
Mise à jour
CVE
CVE-2026-43515
Alias
BIT-tomcat-2026-43515
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Description

Versions Affected: Apache Tomcat 11.0.0-M1 to 11.0.21 Apache Tomcat 10.1.0-M1 to 10.1.54 Apache Tomcat 9.0.0.M1 to 9.0.117 Older, unsupported versions may also be affected Description: When multiple security constraints defined an HTTP method constraint for the same extension pattern, only the first method constraint was applied. Mitigation: Users of the affected versions should apply one of the following mitigations: - Upgrade to Apache Tomcat 11.0.22 or later - Upgrade to Apache Tomcat 10.1.55 or later - Upgrade to Apache Tomcat 9.0.118 or later

Paquets affectés

PaquetVersions
Maven · org.apache.tomcat.embed:tomcat-embed-coreintroduced 0, fixed 9.0.118
Maven · org.apache.tomcat.embed:tomcat-embed-coreintroduced 10.1.0-M1, fixed 10.1.55
Maven · org.apache.tomcat.embed:tomcat-embed-coreintroduced 11.0.0-M1, fixed 11.0.22
Maven · org.apache.tomcat:tomcatintroduced 0, fixed 9.0.118
Maven · org.apache.tomcat:tomcatintroduced 10.1.0-M1, fixed 10.1.55
Maven · org.apache.tomcat:tomcatintroduced 11.0.0-M1, fixed 11.0.22
Maven · org.apache.tomcat:tomcat-catalinaintroduced 0, fixed 9.0.118
Maven · org.apache.tomcat:tomcat-catalinaintroduced 10.1.0-M1, fixed 10.1.55
Maven · org.apache.tomcat:tomcat-catalinaintroduced 11.0.0-M1, fixed 11.0.22

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database