GHSA-5fw9-fq32-wv5p

OS Command Injection in node-notifier

En bref

Publiée
Mise à jour
CVE
CVE-2020-7789
CVSS_V3
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Description

This affects the package node-notifier before 8.0.1. It allows an attacker to run arbitrary commands on Linux machines due to the options params not being sanitised when being passed an array.

Paquets affectés

PaquetVersions
npm · node-notifierintroduced 0, fixed 8.0.1

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database