GHSA-5fvg-qwcp-r325
Apache Ranger Vulnerable to Improper Validation of Certificate with Host Mismatch
At a glance
- Published
- Updated
- CVE
- CVE-2025-59060
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Description
Hostname verification bypass issue in Apache Ranger NiFiRegistryClient/NiFiClient is reported in Apache Ranger versions <= 2.7.0. Users are recommended to upgrade to version 2.8.0, which fixes this issue.
Affected packages
| Package | Versions |
|---|---|
| Maven · org.apache.ranger:ranger-nifi-registry-plugin | introduced 0, fixed 2.8.0 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2025-59060 ADVISORY
- https://github.com/apache/ranger PACKAGE
- https://lists.apache.org/thread/c4plx81z3xs86vgl3fd95y3q7hhtff05 WEB
- http://www.openwall.com/lists/oss-security/2026/03/02/4 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |