GHSA-59c9-pxq8-9c73

Improper JWT Signature Validation in SAP Security Services Library

At a glance

Published
Updated
CVE
CVE-2023-50422, CVE-2023-50424
Aliases
GHSA-92cg-ghq6-9587, GHSA-m8rw-rcpq-2vp2, GO-2023-2400
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Description

### Impact SAP BTP Security Services Integration Library ([Java] cloud-security-services-integration-library) allows under certain conditions an escalation of privileges. On successful exploitation, an unauthenticated attacker can obtain arbitrary permissions within the application. ### Patches Upgrade to patched version >= 2.17.0 or >= 3.3.0 We always recommend to upgrade to the latest released version. ### Workarounds No workarounds ### References https://www.cve.org/CVERecord?id=CVE-2023-50422

Affected packages

PackageVersions
Maven · com.sap.cloud.security:java-securityintroduced 0, fixed 2.17.0
Maven · com.sap.cloud.security:java-securityintroduced 3.0.0, fixed 3.3.0
Maven · com.sap.cloud.security:spring-securityintroduced 0, fixed 2.17.0
Maven · com.sap.cloud.security:spring-securityintroduced 3.0.0, fixed 3.3.0
Maven · com.sap.cloud.security.xsuaa:spring-xsuaaintroduced 0, fixed 2.17.0
Maven · com.sap.cloud.security.xsuaa:spring-xsuaaintroduced 3.0.0, fixed 3.3.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database