GHSA-59c7-4xj2-hgvw

rails-html-sanitizer Cross-site Scripting vulnerability

At a glance

Published
Updated
CVE
CVE-2015-7578
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Description

Cross-site scripting (XSS) vulnerability in the rails-html-sanitizer gem before 1.0.3 for Ruby on Rails 4.2.x and 5.x allows remote attackers to inject arbitrary web script or HTML via crafted tag attributes.

Affected packages

PackageVersions
RubyGems · rails-html-sanitizerintroduced 0, fixed 1.0.3

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database