GHSA-592j-995h-p23j

RDoc RCE vulnerability with .rdoc_options

En bref

Publiée
Mise à jour
CVE
CVE-2024-27281
CVSS_V3
CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N

Description

An issue was discovered in RDoc 6.3.3 through 6.6.2, as distributed in Ruby 3.x through 3.3.0. When parsing `.rdoc_options` (used for configuration in RDoc) as a YAML file, object injection and resultant remote code execution are possible because there are no restrictions on the classes that can be restored. When loading the documentation cache, object injection and resultant remote code execution are also possible if there were a crafted cache. We recommend to update the RDoc gem to version 6.6.3.1 or later. In order to ensure compatibility with bundled version in older Ruby series, you may update as follows instead: * For Ruby 3.0 users: Update to `rdoc` 6.3.4.1 * For Ruby 3.1 users: Update to `rdoc` 6.4.1.1 * For Ruby 3.2 users: Update to `rdoc` 6.5.1.1 You can use `gem update rdoc` to update it. If you are using bundler, please add `gem "rdoc", ">= 6.6.3.1"` to your `Gemfile`. Note: 6.3.4, 6.4.1, 6.5.1 and 6.6.3 have a incorrect fix. We recommend to upgrade 6.3.4.1, 6.4.1.1, 6.5.1.1 and 6.6.3.1 instead of them.

Paquets affectés

PaquetVersions
RubyGems · rdocintroduced 6.3.3, fixed 6.3.4.1
RubyGems · rdocintroduced 6.4.0, fixed 6.4.1.1
RubyGems · rdocintroduced 6.5.0, fixed 6.5.1.1
RubyGems · rdocintroduced 6.6.0, fixed 6.6.3.1

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database