GHSA-58jx-f5rf-qgqf

User account escalation in Apache Hadoop

At a glance

Published
Updated
CVE
CVE-2021-33036
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Description

In Apache Hadoop 2.2.0 to 2.10.1, 3.0.0-alpha1 to 3.1.4, 3.2.0 to 3.2.2, and 3.3.0 to 3.3.1, a user who can escalate to yarn user can possibly run arbitrary commands as root user. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.

Affected packages

PackageVersions
Maven · org.apache.hadoop:hadoop-yarn-server-commonintroduced 2.2.0, fixed 2.10.2
Maven · org.apache.hadoop:hadoop-yarn-server-commonintroduced 3.0.0, fixed 3.2.3
Maven · org.apache.hadoop:hadoop-yarn-server-commonintroduced 3.3.0, fixed 3.3.2

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database