GHSA-585j-5449-mf5m

Drupal cross-site scripting vulnerability

En bref

Publiée
Mise à jour
CVE
CVE-2017-6927
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Description

Drupal 8.4.x versions before 8.4.5 and Drupal 7.x versions before 7.57 has a Drupal.checkPlain() JavaScript function which is used to escape potentially dangerous text before outputting it to HTML (as JavaScript output does not typically go through Twig autoescaping). This function does not correctly handle all methods of injecting malicious HTML, leading to a cross-site scripting vulnerability under certain circumstances. The PHP functions which Drupal provides for HTML escaping are not affected.

Paquets affectés

PaquetVersions
Packagist · drupal/coreintroduced 8.4.0, fixed 8.4.5
Packagist · drupal/coreintroduced 7.0, fixed 7.57
Packagist · drupal/drupalintroduced 8.4.0, fixed 8.4.5
Packagist · drupal/drupalintroduced 7.0, fixed 7.57

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database