GHSA-564r-hj7v-mcr5

Spring Framework vulnerable to denial of service via specially crafted SpEL expression

At a glance

Published
Updated
CVE
CVE-2023-20861
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Description

In Spring Framework versions 6.0.0 - 6.0.6, 5.3.0 - 5.3.25, 5.2.0.RELEASE - 5.2.22.RELEASE, and older unsupported versions, it is possible for a user to provide a specially crafted SpEL expression that may cause a denial-of-service (DoS) condition.

Affected packages

PackageVersions
Maven · org.springframework:spring-expressionintroduced 6.0.0, fixed 6.0.7
Maven · org.springframework:spring-expressionintroduced 5.3.0, fixed 5.3.26
Maven · org.springframework:spring-expressionintroduced 0, fixed 5.2.23.RELEASE

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database