GHSA-562c-5r94-xh97

Flask is vulnerable to Denial of Service via incorrect encoding of JSON data

At a glance

Published
Updated
CVE
CVE-2018-1000656
Aliases
PYSEC-2018-66
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Description

The Pallets Project flask version Before 0.12.3 contains a CWE-20: Improper Input Validation vulnerability in flask that can result in Large amount of memory usage possibly leading to denial of service. This attack appear to be exploitable via Attacker provides JSON data in incorrect encoding. This vulnerability appears to have been fixed in 0.12.3.

Affected packages

PackageVersions
PyPI · flaskintroduced 0, fixed 0.12.3

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database