GHSA-54rr-7fvw-6x8f

Rack Header Parsing leads to Possible Denial of Service Vulnerability

At a glance

Published
Updated
CVE
CVE-2024-26146

Description

# Possible Denial of Service Vulnerability in Rack Header Parsing There is a possible denial of service vulnerability in the header parsing routines in Rack. This vulnerability has been assigned the CVE identifier CVE-2024-26146. Versions Affected: All. Not affected: None Fixed Versions: 2.0.9.4, 2.1.4.4, 2.2.8.1, 3.0.9.1 Impact ------ Carefully crafted headers can cause header parsing in Rack to take longer than expected resulting in a possible denial of service issue. Accept and Forwarded headers are impacted. Ruby 3.2 has mitigations for this problem, so Rack applications using Ruby 3.2 or newer are unaffected. Releases -------- The fixed releases are available at the normal locations. Workarounds ----------- There are no feasible workarounds for this issue. Patches ------- To aid users who aren't able to upgrade immediately we have provided patches for the two supported release series. They are in git-am format and consist of a single changeset. * 2-0-header-redos.patch - Patch for 2.0 series * 2-1-header-redos.patch - Patch for 2.1 series * 2-2-header-redos.patch - Patch for 2.2 series * 3-0-header-redos.patch - Patch for 3.0 series Credits ------- Thanks to [svalkanov](https://hackerone.com/svalkanov) for reporting this and providing patches!

Affected packages

PackageVersions
RubyGems · rackintroduced 3.0.0, fixed 3.0.9.1
RubyGems · rackintroduced 2.2.0, fixed 2.2.8.1
RubyGems · rackintroduced 2.1.0, fixed 2.1.4.4
RubyGems · rackintroduced 0, fixed 2.0.9.4

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database