GHSA-543v-gj2c-r3ch

activemodel contains Improper Input Validation

En bref

Publiée
Mise à jour
CVE
CVE-2016-0753
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Description

Active Model in Ruby on Rails 4.1.x before 4.1.14.1, 4.2.x before 4.2.5.1, and 5.x before 5.0.0.beta1.1 supports the use of instance-level writers for class accessors, which allows remote attackers to bypass intended validation steps via crafted parameters.

Paquets affectés

PaquetVersions
RubyGems · activemodelintroduced 4.1.0, fixed 4.1.14.1
RubyGems · activemodelintroduced 4.2.0, fixed 4.2.5.1

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database