GHSA-4wm8-fjv7-j774
RubyGems Escape sequence injection in errors
At a glance
- Published
- Updated
- CVE
- CVE-2019-8325
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Description
An issue was discovered in RubyGems 2.6 and later through 3.0.2. Since Gem::CommandManager#run calls alert_error without escaping, escape sequence injection is possible. (There are many ways to cause an error.)
Affected packages
| Package | Versions |
|---|---|
| RubyGems · rubygems-update | introduced 2.6.0, fixed 2.7.9 |
| RubyGems · rubygems-update | introduced 3.0.0, fixed 3.0.2 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-8325 ADVISORY
- https://blog.rubygems.org/2019/03/05/security-advisories-2019-03.html WEB
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rubygems-update/CVE-2019-8325.yml WEB
- https://lists.debian.org/debian-lts-announce/2020/08/msg00027.html WEB
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00036.html WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |