GHSA-4wm8-fjv7-j774

RubyGems Escape sequence injection in errors

At a glance

Published
Updated
CVE
CVE-2019-8325
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Description

An issue was discovered in RubyGems 2.6 and later through 3.0.2. Since Gem::CommandManager#run calls alert_error without escaping, escape sequence injection is possible. (There are many ways to cause an error.)

Affected packages

PackageVersions
RubyGems · rubygems-updateintroduced 2.6.0, fixed 2.7.9
RubyGems · rubygems-updateintroduced 3.0.0, fixed 3.0.2

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database