GHSA-4w2j-2rg4-5mjw

vm2 vulnerable to Arbitrary Code Execution

At a glance

Published
Updated
CVE
CVE-2022-25893
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

The package vm2 before 3.9.10 is vulnerable to Arbitrary Code Execution due to the usage of prototype lookup for the WeakMap.prototype.set method. Exploiting this vulnerability leads to access to a host object and a sandbox compromise.

Affected packages

PackageVersions
npm · vm2introduced 0, fixed 3.9.10

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database