GHSA-4pg4-qvpc-4q3h

Multer vulnerable to Denial of Service from maliciously crafted requests

En bref

Publiée
Mise à jour
CVE
CVE-2025-47944
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Description

### Impact A vulnerability in Multer versions >=1.4.4-lts.1 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed multi-part upload request. This request causes an unhandled exception, leading to a crash of the process. ### Patches Users should upgrade to `2.0.0` ### Workarounds None ### References - https://github.com/expressjs/multer/issues/1176 - https://github.com/expressjs/multer/commit/2c8505f207d923dd8de13a9f93a4563e59933665

Paquets affectés

PaquetVersions
npm · multerintroduced 1.4.4-lts.1, fixed 2.0.0

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database