GHSA-4p5m-gvpf-f3x5

Apache Solr Relative Path Traversal vulnerability

At a glance

Published
Updated
CVE
CVE-2024-52012
Aliases
BIT-solr-2024-52012
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:U

Description

Relative Path Traversal vulnerability in Apache Solr. Solr instances running on Windows are vulnerable to arbitrary filepath write-access, due to a lack of input-sanitation in the "configset upload" API.  Commonly known as a "zipslip", maliciously constructed ZIP files can use relative filepaths to write data to unanticipated parts of the filesystem.   This issue affects Apache Solr: from 6.6 through 9.7.0. Users are recommended to upgrade to version 9.8.0, which fixes the issue.  Users unable to upgrade may also safely prevent the issue by using Solr's "Rule-Based Authentication Plugin" to restrict access to the configset upload API, so that it can only be accessed by a trusted set of administrators/users.

Affected packages

PackageVersions
Maven · org.apache.solr:solr-coreintroduced 6.6, fixed 9.8.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database