GHSA-4p24-vmcr-4gqj

Bootstrap Cross-site Scripting vulnerability

At a glance

Published
Updated
CVE
CVE-2016-10735
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Description

In Bootstrap 2.x from 2.0.4, 3.x before 3.4.0 and 4.x-beta before 4.0.0-beta.2, XSS is possible in the data-target attribute. Note that this is a different vulnerability than CVE-2018-14041. See https://blog.getbootstrap.com/2018/12/13/bootstrap-3-4-0/ for more info.

Affected packages

PackageVersions
npm · bootstrapintroduced 2.0.4, fixed 3.4.0
npm · bootstrapintroduced 4.0.0-beta, fixed 4.0.0-beta.2
Maven · org.webjars:bootstrapintroduced 2.0.4, fixed 3.4.0
Maven · org.webjars:bootstrapintroduced 4.0.0-beta, fixed 4.0.0-beta.2
RubyGems · bootstrapintroduced 0, fixed 4.0.0-beta.2
Packagist · twbs/bootstrapintroduced 2.0.4, fixed 3.4.0
Packagist · twbs/bootstrapintroduced 4.0.0-beta, fixed 4.0.0-beta.2
NuGet · bootstrapintroduced 2.0.4, fixed 3.4.0
NuGet · bootstrapintroduced 4.0.0-beta, fixed 4.0.0-beta.2
npm · bootstrap-sassintroduced 2.0.4, fixed 3.4.0
RubyGems · bootstrap-sassintroduced 2.0.4, fixed 3.4.0
NuGet · bootstrap.sassintroduced 4.0.0-beta, fixed 4.0.0-beta.2

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database