GHSA-4hrm-m67v-5cxr

XStream is vulnerable to an Arbitrary Code Execution attack

At a glance

Published
Updated
CVE
CVE-2021-21346
Aliases
BIT-activemq-2021-21346
CVSS_V3
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:N/I:H/A:N

Description

### Impact The vulnerability may allow a remote attacker to load and execute arbitrary code from a remote host only by manipulating the processed input stream. No user is affected, who followed the recommendation to setup XStream's security framework with a whitelist limited to the minimal required types. ### Patches If you rely on XStream's default blacklist of the [Security Framework](https://x-stream.github.io/security.html#framework), you will have to use at least version 1.4.16. ### Workarounds See [workarounds](https://x-stream.github.io/security.html#workaround) for the different versions covering all CVEs. ### References See full information about the nature of the vulnerability and the steps to reproduce it in XStream's documentation for [CVE-2021-21346](https://x-stream.github.io/CVE-2021-21346.html). ### Credits wh1t3p1g G5-RD6@IIE found and reported the issue to XStream and provided the required information to reproduce it. ### For more information If you have any questions or comments about this advisory: * Open an issue in [XStream](https://github.com/x-stream/xstream/issues) * Contact us at [XStream Google Group](https://groups.google.com/group/xstream-user)

Affected packages

PackageVersions
Maven · com.thoughtworks.xstream:xstreamintroduced 0, fixed 1.4.16

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database