GHSA-4hfh-6x8g-gwpp

Spring Framework Escalation via Session Fixation in WebFlux

En bref

Publiée
Mise à jour
CVE
CVE-2026-41839
CVSS_V3
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N

Description

A WebFlux application with a compromised subdomain (for example, compromised via cross-site scripting (XSS)) is vulnerable to an escalation attack exchanging a known session ID for that of an authenticated user. Affected versions: Spring Framework 7.0.0 through 7.0.7; 6.2.0 through 6.2.18; 6.1.0 through 6.1.27; 5.3.0 through 5.3.48.

Paquets affectés

PaquetVersions
Maven · org.springframework:spring-webfluxintroduced 7.0.0, fixed 7.0.8
Maven · org.springframework:spring-webfluxintroduced 6.2.0, fixed 6.2.19
Maven · org.springframework:spring-webfluxintroduced 6.1.0, last affected 6.1.21
Maven · org.springframework:spring-webfluxintroduced 0, last affected 5.3.39

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database