GHSA-4g9r-vxhx-9pgx
Apache Commons Compress: Denial of service caused by an infinite loop for a corrupted DUMP file
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2024-25710
- CVSS_V3
- CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:N/I:N/A:H
Description
Loop with Unreachable Exit Condition ('Infinite Loop') vulnerability in Apache Commons Compress. This issue affects Apache Commons Compress: from 1.3 through 1.25.0. Users are recommended to upgrade to version 1.26.0 which fixes the issue.
Paquets affectés
| Paquet | Versions |
|---|---|
| Maven · org.apache.commons:commons-compress | introduced 1.3, fixed 1.26.0 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2024-25710 ADVISORY
- https://github.com/apache/commons-compress PACKAGE
- https://lists.apache.org/thread/cz8qkcwphy4cx8gltn932ln51cbtq6kf WEB
- https://security.netapp.com/advisory/ntap-20240307-0010 WEB
- http://seclists.org/fulldisclosure/2024/Aug/37 WEB
- http://www.openwall.com/lists/oss-security/2024/02/19/1 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |