GHSA-4fc4-4p5g-6w89

Cross-site Scripting in CKEditor4

En bref

Publiée
Mise à jour
CVE
CVE-2022-24728, CVE-2022-24729
Alias
BIT-drupal-2022-24728, BIT-drupal-2022-24729, DRUPAL-CORE-2022-005, GHSA-f6rf-9m92-x2hh
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Description

### Affected packages The vulnerability has been discovered in the core HTML processing module and may affect all plugins used by CKEditor 4. ### Impact A potential vulnerability has been discovered in CKEditor 4 HTML processing core module. The vulnerability allowed to inject malformed HTML bypassing content sanitization, which could result in executing JavaScript code. It affects all users using the CKEditor 4 at version < 4.18.0. ### Patches The problem has been recognized and patched. The fix will be available in version 4.18.0. ### For more information Email us at security@cksource.com if you have any questions or comments about this advisory. ### Acknowledgements The CKEditor 4 team would like to thank GHSL team member Kevin Backhouse ([@kevinbackhouse](https://github.com/kevinbackhouse)) for recognizing and reporting this vulnerability.

Paquets affectés

PaquetVersions
npm · ckeditor4introduced 0, fixed 4.18.0

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database