GHSA-4c7m-wxvm-r7gc

Improper parsing of octal bytes in netmask

At a glance

Published
Updated
CVE
CVE-2021-28918, CVE-2021-29418
Aliases
GHSA-pch5-whg9-qr2r
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Description

Improper input validation of octal strings in netmask npm package v1.0.6 and below allows unauthenticated remote attackers to perform indeterminate SSRF, RFI, and LFI attacks on many of the dependent packages. A remote unauthenticated attacker can bypass packages relying on netmask to filter IPs and reach critical VPN or LAN hosts. :exclamation: NOTE: The fix for this issue was incomplete. A subsequent fix was made in version `2.0.1` which was assigned [CVE-2021-29418 / GHSA-pch5-whg9-qr2r](https://github.com/advisories/GHSA-pch5-whg9-qr2r). For complete protection from this vulnerability an upgrade to version 2.0.1 or later is recommended.

Affected packages

PackageVersions
npm · netmaskintroduced 0, fixed 1.1.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database