GHSA-4c6x-gfc8-c26r

Apache Tomcat Vulnerable to Cross-Site Scripting

En bref

Publiée
Mise à jour
CVE
CVE-2007-1355
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

Description

Multiple cross-site scripting (XSS) vulnerabilities in the appdev/sample/web/hello.jsp example application in Tomcat 4.0.0 through 4.0.6, 4.1.0 through 4.1.36, 5.0.0 through 5.0.30, 5.5.0 through 5.5.23, and 6.0.0 through 6.0.10 allow remote attackers to inject arbitrary web script or HTML via the test parameter and unspecified vectors.

Paquets affectés

PaquetVersions
Maven · org.apache.tomcat:jsp-apiintroduced 4.1.0, fixed 4.1.37
Maven · org.apache.tomcat:jsp-apiintroduced 5.5.0, fixed 5.5.24
Maven · org.apache.tomcat:jsp-apiintroduced 6.0.0, fixed 6.0.11
Maven · org.apache.tomcat:jsp-apiintroduced 5.0.0, last affected 5.0.30
Maven · org.apache.tomcat:jsp-apiintroduced 4.0.0, last affected 4.0.6
Maven · org.apache.tomcat:servlet-apiintroduced 4.1.0, fixed 4.1.37
Maven · org.apache.tomcat:servlet-apiintroduced 5.5.0, fixed 5.5.24
Maven · org.apache.tomcat:servlet-apiintroduced 6.0.0, fixed 6.0.11
Maven · org.apache.tomcat:servlet-apiintroduced 5.0.0, last affected 5.0.30
Maven · org.apache.tomcat:servlet-apiintroduced 4.0.0, last affected 4.0.6

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database