GHSA-4c43-cwvx-9crh

Improper Access Control in Apache Tomcat

At a glance

Published
Updated
CVE
CVE-2014-7810

Description

The Expression Language (EL) implementation in Apache Tomcat 6.x before 6.0.44, 7.x before 7.0.58, and 8.x before 8.0.16 does not properly consider the possibility of an accessible interface implemented by an inaccessible class, which allows attackers to bypass a SecurityManager protection mechanism via a web application that leverages use of incorrect privileges during EL evaluation.

Affected packages

PackageVersions
Maven · org.apache.tomcat:tomcatintroduced 6.0.0, fixed 6.0.44
Maven · org.apache.tomcat:tomcatintroduced 7.0.0, fixed 7.0.58
Maven · org.apache.tomcat:tomcatintroduced 8.0.0, fixed 8.0.16

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database