GHSA-49mv-vfcp-8gg9

Moodle vulnerable to SQL Injection

En bref

Publiée
Mise à jour
CVE
CVE-2023-35132
Alias
BIT-moodle-2023-35132
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

Description

A limited SQL injection risk was identified on the Mnet SSO access control page. This flaw affects Moodle versions 4.2, 4.1 to 4.1.3, 4.0 to 4.0.8, 3.11 to 3.11.14, 3.9 to 3.9.21 and earlier unsupported versions.

Paquets affectés

PaquetVersions
Packagist · moodle/moodleintroduced 4.2.0, fixed 4.2.1
Packagist · moodle/moodleintroduced 4.1.0, fixed 4.1.4
Packagist · moodle/moodleintroduced 4.0.0, fixed 4.0.9
Packagist · moodle/moodleintroduced 3.10.0, fixed 3.11.15
Packagist · moodle/moodleintroduced 0, fixed 3.9.22

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database