GHSA-47w3-66wq-cpxg

Improper Input Validation in Apache Kafka

En bref

Publiée
Mise à jour
CVE
CVE-2018-17196
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Description

In Apache Kafka versions between 0.11.0.0 and 2.1.0, it is possible to manually craft a Produce request which bypasses transaction/idempotent ACL validation. Only authenticated clients with Write permission on the respective topics are able to exploit this vulnerability. Users should upgrade to 2.1.1 or later where this vulnerability has been fixed.

Paquets affectés

PaquetVersions
Maven · org.apache.kafka:kafkaintroduced 0.11.0.0, fixed 2.1.1

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database