GHSA-46jf-c9vx-hh79

Apache Camel-Couchbase: Non-Camel-prefixed Exchange headers bypass HeaderFilterStrategy allowing operation override from untrusted input

At a glance

Published
Updated
CVE
CVE-2026-46587
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Description

Improper Input Validation vulnerability in Apache Camel. This issue affects Apache Camel: through 4.14.7, from 4.15.0 through 4.18.2, from 4.19.0 through 4.20.0. Users are recommended to upgrade to version 4.14.8, 4.18.3, 4.21.0, which fixes the issue.

Affected packages

PackageVersions
Maven · org.apache.camel:camel-couchbaseintroduced 4.0.0, fixed 4.14.8
Maven · org.apache.camel:camel-couchbaseintroduced 4.15.0, fixed 4.18.3
Maven · org.apache.camel:camel-couchbaseintroduced 4.19.0, fixed 4.21.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database