GHSA-4588-7x48-jrgj
Magento Open Source allows Server-Side Request Forgery (SSRF)
At a glance
- Published
- Updated
- CVE
- CVE-2023-29292
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:U
Description
Adobe Commerce versions 2.4.6 (and earlier), 2.4.5-p2 (and earlier) and 2.4.4-p3 (and earlier) are affected by a Server-Side Request Forgery (SSRF) vulnerability that could lead to arbitrary file system read. An admin-privilege authenticated attacker can force the application to make arbitrary requests via injection of arbitrary URLs. Exploitation of this issue does not require user interaction.
Affected packages
| Package | Versions |
|---|---|
| Packagist · magento/community-edition | 2.4.6 |
| Packagist · magento/community-edition | 2.4.5 |
| Packagist · magento/community-edition | 2.4.4 |
| Packagist · magento/community-edition | introduced 2.4.5-p1, fixed 2.4.5-p3 |
| Packagist · magento/community-edition | introduced 2.4.4-p1, fixed 2.4.4-p4 |
| Packagist · magento/project-community-edition | introduced 0, last affected 2.0.2 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2023-29292 ADVISORY
- https://github.com/magento/magento2 PACKAGE
- https://helpx.adobe.com/security/products/magento/apsb23-35.html WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |