GHSA-44wm-f244-xhp3

Pillow buffer overflow vulnerability

At a glance

Published
Updated
CVE
CVE-2024-28219
Aliases
BIT-pillow-2024-28219, PYSEC-2026-1793
CVSS_V3
CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Description

In _imagingcms.c in Pillow before 10.3.0, a buffer overflow exists because strcpy is used instead of strncpy.

Affected packages

PackageVersions
PyPI · pillowintroduced 0, fixed 10.3.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database