GHSA-44c3-38h8-9fh9

Apache Jackrabbit vulnerable to blind XXE attack due to insecure document build

En bref

Publiée
Mise à jour
CVE
CVE-2025-53689
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Description

Blind XXE vulnerabilities in jackrabbit-spi-commons and jackrabbit-core in Apache Jackrabbit < 2.23.2 due to usage of an unsecured document build to load privileges. Users are recommended to upgrade to versions 2.20.17 (Java 8), 2.22.1 (Java 11) or 2.23.2 (Java 11, beta versions), which fix this issue. Earlier versions (up to 2.20.16) are not supported anymore, thus users should update to the respective supported version.

Paquets affectés

PaquetVersions
Maven · org.apache.jackrabbit:jackrabbit-spi-commonsintroduced 2.20.0, fixed 2.20.17
Maven · org.apache.jackrabbit:jackrabbit-spi-commonsintroduced 2.22.0, fixed 2.22.1
Maven · org.apache.jackrabbit:jackrabbit-spi-commonsintroduced 2.23.0-beta, fixed 2.23.2-beta
Maven · org.apache.jackrabbit:jackrabbit-coreintroduced 2.23.0-beta, fixed 2.23.2-beta
Maven · org.apache.jackrabbit:jackrabbit-coreintroduced 2.20.0, fixed 2.20.17
Maven · org.apache.jackrabbit:jackrabbit-coreintroduced 2.22.0, fixed 2.22.1

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database