GHSA-449q-v4j2-5h8p
Jenkins allows Exposure of Sensitive Information to an Unauthorized Actor
At a glance
- Published
- Updated
- CVE
- CVE-2015-5320
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
Description
Jenkins before 1.638 and LTS before 1.625.2 do not properly verify the shared secret used in JNLP slave connections, which allows remote attackers to connect as slaves and obtain sensitive information or possibly gain administrative access by leveraging knowledge of the name of a slave.
Affected packages
| Package | Versions |
|---|---|
| Maven · org.jenkins-ci.main:jenkins-core | introduced 1.626, fixed 1.638 |
| Maven · org.jenkins-ci.main:jenkins-core | introduced 0, fixed 1.625.2 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2015-5320 ADVISORY
- https://access.redhat.com/errata/RHSA-2016:0070 WEB
- https://github.com/jenkinsci/jenkins PACKAGE
- https://wiki.jenkins-ci.org/display/SECURITY/Jenkins+Security+Advisory+2015-11-11 WEB
- http://rhn.redhat.com/errata/RHSA-2016-0489.html WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |