GHSA-43xg-8wmj-cw8h

Apache Spark vulnerable to Log Injection

En bref

Publiée
Mise à jour
CVE
CVE-2022-31777
Alias
BIT-spark-2022-31777, PYSEC-2022-42976
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Description

A stored cross-site scripting (XSS) vulnerability in Apache Spark 3.2.1 and earlier, and 3.3.0, allows remote attackers to execute arbitrary JavaScript in the web browser of a user, by including a malicious payload into the logs which would be returned in logs rendered in the UI.

Paquets affectés

PaquetVersions
PyPI · pysparkintroduced 0, fixed 3.2.2
PyPI · pysparkintroduced 3.3.0, fixed 3.3.1
Maven · org.apache.spark:spark-core_2.9.3introduced 0
Maven · org.apache.spark:spark-core_2.13introduced 0, fixed 3.2.2
Maven · org.apache.spark:spark-core_2.13introduced 3.3.0, fixed 3.3.1
Maven · org.apache.spark:spark-core_2.12introduced 0, fixed 3.2.2
Maven · org.apache.spark:spark-core_2.12introduced 3.3.0, fixed 3.3.1
Maven · org.apache.spark:spark-core_2.11introduced 0
Maven · org.apache.spark:spark-core_2.10introduced 0

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database