GHSA-4328-8hgf-7wjr

npm Vulnerable to Global node_modules Binary Overwrite

At a glance

Published
Updated
CVE
CVE-2019-16777
CVSS_V3
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N

Description

Versions of the npm CLI prior to 6.13.4 are vulnerable to a Global node_modules Binary Overwrite. It fails to prevent existing globally-installed binaries to be overwritten by other package installations. For example, if a package was installed globally and created a `serve` binary, any subsequent installs of packages that also create a `serve` binary would overwrite the first binary. This will not overwrite system binaries but only binaries put into the global node_modules directory. This behavior is still allowed in local installations and also through install scripts. This vulnerability bypasses a user using the --ignore-scripts install option. ## Recommendation Upgrade to version 6.13.4 or later.

Affected packages

PackageVersions
npm · npmintroduced 0, fixed 6.13.4

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database