GHSA-3wqf-4x89-9g79

Bootstrap vulnerable to Cross-Site Scripting (XSS)

En bref

Publiée
Mise à jour
CVE
CVE-2018-14040
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Description

In Bootstrap starting in version 2.3.0 and prior to 3.4.0, as well as 4.x before 4.1.2, XSS is possible in the collapse data-parent attribute.

Paquets affectés

PaquetVersions
npm · bootstrapintroduced 4.0.0, fixed 4.1.2
RubyGems · bootstrapintroduced 4.0.0, fixed 4.1.2
npm · bootstrapintroduced 2.3.0, fixed 3.4.0
RubyGems · bootstrapintroduced 2.3.0, fixed 3.4.0
Maven · org.webjars:bootstrapintroduced 4.0.0, fixed 4.1.2
Maven · org.webjars:bootstrapintroduced 2.3.0, fixed 3.4.0
NuGet · bootstrapintroduced 2.3.0, fixed 3.4.0
NuGet · bootstrapintroduced 4.0.0, fixed 4.1.2
NuGet · bootstrap.sassintroduced 4.0.0, fixed 4.1.2
RubyGems · bootstrap-sassintroduced 2.3.0, fixed 3.4.0
Packagist · twbs/bootstrapintroduced 2.3.0, fixed 3.4.0
Packagist · twbs/bootstrapintroduced 4.0.0, fixed 4.1.2

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database