GHSA-3vp4-m3rf-835h

Improper input validation in github.com/gin-gonic/gin

At a glance

Published
Updated
CVE
CVE-2023-26125
CVSS_V3
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Description

Versions of the package github.com/gin-gonic/gin before version 1.9.0 are vulnerable to Improper Input Validation by allowing an attacker to use a specially crafted request via the X-Forwarded-Prefix header, potentially leading to cache poisoning. **Note:** Although this issue does not pose a significant threat on its own it can serve as an input vector for other more impactful vulnerabilities. However, successful exploitation may depend on the server configuration and whether the header is used in the application logic.

Affected packages

PackageVersions
Go · github.com/gin-gonic/ginintroduced 0, fixed 1.9.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database