GHSA-3v7g-4pg3-7r6j
OS Command injection in Apache Airflow
At a glance
- Published
- Updated
- CVE
- CVE-2022-24288
- Aliases
- BIT-airflow-2022-24288, PYSEC-2022-30
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Description
In Apache Airflow, prior to version 2.2.4, some example DAGs did not properly sanitize user-provided params, making them susceptible to OS Command Injection from the web UI.
Affected packages
| Package | Versions |
|---|---|
| PyPI · apache-airflow | introduced 0, fixed 2.2.4 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-24288 ADVISORY
- https://github.com/advisories/GHSA-3v7g-4pg3-7r6j ADVISORY
- https://github.com/apache/airflow PACKAGE
- https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2022-30.yaml WEB
- https://lists.apache.org/thread/dbw5ozcmr0h0lhs0yjph7xdc64oht23t WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |