GHSA-3q5x-7mxp-rp6j

Remote code execution via vulnerable Symphony dependecy injection

At a glance

Published
Updated
CVE
CVE-2019-8135
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

A remote code execution vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. Dependency injection through Symphony framework allows service identifiers to be derived from user controlled data, which can lead to remote code execution. As per [the Magento Release 2.3.3](https://web.archive.org/web/20201126132230/https://devdocs.magento.com/guides/v2.3/release-notes/release-notes-2-3-3-commerce.html#new-security-only-patch-available), if you have already implemented the pre-release version of this patch (2.3.2-p1), it is highly recommended to promptly upgrade to 2.3.2-p2.

Affected packages

PackageVersions
Packagist · magento/community-editionintroduced 2.2, fixed 2.2.10
Packagist · magento/community-editionintroduced 2.3, fixed 2.3.2-p2

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database