GHSA-3p2h-wqq4-wf4h

Apache Tomcat Denial of Service via invalid HTTP priority header

At a glance

Published
Updated
CVE
CVE-2025-31650
Aliases
BIT-tomcat-2025-31650
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U

Description

Improper Input Validation vulnerability in Apache Tomcat. Incorrect error handling for some invalid HTTP priority headers resulted in incomplete clean-up of the failed request which created a memory leak. A large number of such requests could trigger an OutOfMemoryException resulting in a denial of service. This issue affects Apache Tomcat: from 9.0.76 through 9.0.102, from 10.1.10 through 10.1.39, from 11.0.0-M2 through 11.0.5. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.90 though 8.5.100. Users are recommended to upgrade to version 9.0.104, 10.1.40 or 11.0.6 which fix the issue.

Affected packages

PackageVersions
Maven · org.apache.tomcat:tomcat-coyoteintroduced 9.0.76, fixed 9.0.104
Maven · org.apache.tomcat:tomcat-coyoteintroduced 10.1.10, fixed 10.1.40
Maven · org.apache.tomcat:tomcat-coyoteintroduced 11.0.0-M2, fixed 11.0.6
Maven · org.apache.tomcat.embed:tomcat-embed-coreintroduced 9.0.76, fixed 9.0.104
Maven · org.apache.tomcat.embed:tomcat-embed-coreintroduced 10.1.10, fixed 10.1.40
Maven · org.apache.tomcat.embed:tomcat-embed-coreintroduced 11.0.0-M2, fixed 11.0.6
Maven · org.apache.tomcat:tomcat-coyoteintroduced 8.5.0, last affected 8.5.100
Maven · org.apache.tomcat.embed:tomcat-embed-coreintroduced 8.5.0, last affected 8.5.100

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database