GHSA-3m36-mjwj-352c

Drupal core Cross-site Scripting (XSS) vulnerability

En bref

Publiée
Mise à jour
CVE
CVE-2020-13672
Alias
BIT-drupal-2020-13672, DRUPAL-CORE-2021-002
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Description

Cross-site Scripting (XSS) vulnerability in Drupal core's sanitization API fails to properly filter cross-site scripting under certain circumstances. This issue affects: Drupal Core 9.1.x versions prior to 9.1.7; 9.0.x versions prior to 9.0.12; 8.9.x versions prior to 8.9.14; 7.x versions prior to 7.80.

Paquets affectés

PaquetVersions
Packagist · drupal/coreintroduced 7.0.0, fixed 7.80
Packagist · drupal/coreintroduced 8.0.0, fixed 8.9.14
Packagist · drupal/coreintroduced 9.0.0, fixed 9.0.12
Packagist · drupal/coreintroduced 9.1.0, fixed 9.1.7
Packagist · drupal/drupalintroduced 7.0.0, fixed 7.80
Packagist · drupal/drupalintroduced 8.0.0, fixed 8.9.14
Packagist · drupal/drupalintroduced 9.0.0, fixed 9.0.12
Packagist · drupal/drupalintroduced 9.1.0, fixed 9.1.7

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database