GHSA-3jrj-x6cj-97cp

Moodle contains CSRF vulnerability

At a glance

Published
Updated
CVE
CVE-2021-43559
Aliases
BIT-moodle-2021-43559
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Description

A flaw was found in Moodle in versions 3.11 to 3.11.3, 3.10 to 3.10.7, 3.9 to 3.9.10 and earlier unsupported versions. The "delete related badge" functionality did not include the necessary token check to prevent a CSRF risk.

Affected packages

PackageVersions
Packagist · moodle/moodleintroduced 3.11, fixed 3.11.4
Packagist · moodle/moodleintroduced 3.10, fixed 3.10.8
Packagist · moodle/moodleintroduced 3.9, fixed 3.9.11

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database